NPM更新依赖版本

65次阅读
没有评论

平时开发会遇到很多组件库一直在更新,旧项目想使用,但是本地版本又不是最新的,左右为难。

以下用腾讯开源组件库为例,进行简单的说明:

1、首先查看指定包的版本:

// 查看最新版本
npm view tdesign-miniprogram version
// 查看所有版本
npm view tdesign-miniprogram versions

2、安装指定新版本

// 安装最新版本覆盖旧版本
npm install tdesign-miniprogram@0.19.2
  • 使用 update 更新
// 项目对应依赖包一般保存在 package.json 文件中,相对应版本号的形式为 mojor.minor.patch
major 表示非兼容的重大 API 改变(主要的)minor 表示向后兼容的功能性改变(次要的)patch 表示向后兼容的 bug 修正(修补的)// 依赖包对应版本号前缀符号含义
* 匹配最新的 major 版本依赖包
^ 匹配最新的 minor 版本依赖包,eg: 1.1.0 可以更新匹配所有 1.x.x 的包,不会更新匹配  2.x.x
~ 匹配最新的 patch 版本依赖包,eg: 1.1.0 可以更新匹配所有 1.1.x 的包,不会更新匹配  1.2.x

更新指定依赖安装包(根据前缀符号更新,有时需要在 package.json 手动更改依赖包相应版本号再更新)

npm update tdesign-miniprogram -S  (--save/-S or --save-dev/-D)

加入官方交流QQ群:778957856
post-qrcode
clark
版权声明:本站原创文章,由 clark 2022-08-24发表,共计596字。
转载说明:除特殊说明外本站文章皆由CC-4.0协议发布,转载请注明出处。
评论(没有评论)
验证码